ModWorkshop
Payday 2: You're crashing with the new U153 and BLT 2.0? - Printable Version

+- ModWorkshop (https://modworkshop.net)
+-- Forum: Site (https://modworkshop.net/forumdisplay.php?fid=84)
+--- Forum: News (https://modworkshop.net/forumdisplay.php?fid=10)
+--- Thread: Payday 2: You're crashing with the new U153 and BLT 2.0? (/showthread.php?tid=7275)

Pages: 1 2 3 4


Payday 2: You're crashing with the new U153 and BLT 2.0? - Alcat101 - 08-31-2017

If you're crashing at the start of the game after updating Payday 2 Update 153 (Luajit changes)
And after updating BLT into BLT 2.0: https://github.com/JamesWilko/Payday-2-BLT/releases

It might be because of tons of mods you use.


Here's some mods that I've removed from mods folder, after the first attempt to launch PD2, ends up in CTD
Removing this mods, makes the game stable enough to go to main menu
- BetterLightFX
- Bodhi's War Repair
- Poser
- Safehouse-Plus
- Sentry Contours
- Update All mods
- Melee Overhaul REvamped


BLT 2.1 update have been released and fixes the major issues of previous version.
3 CONFIRMED ISSUE WITH BLT 2.0, READ THIS FIRST:
Spoiler!
  1. BLT 2.0 doesn't work with Windows 7 atm
    https://github.com/JamesWilko/Payday-2-BLT/issues/95

  2. BLT 2.0 will crash the user when trying to join someone else's ongoing heist. (Joining on lobby is fine, but when on Heist Start screen, after everyone is ready-ing up, user will crash.
    https://github.com/JamesWilko/Payday-2-BLT/issues/89
    *Hosting the game seems to be fine, player can join you without crash. But player with BLT 2.0 will dc (crash on their end)

  3. BLT 2.0 Auto-Update system currently doesn't work properly. BLT 2.0 will tell there's an update to some of your BLT mod, even though you already using the most recent and fixed version for BLT 2.0 format.
    https://github.com/JamesWilko/Payday-2-BLT/issues/90
    *Initiating the udpate, will just finishes it and telling there's an error and asking for a retry. Your mod files isnt touched at all.


This issues above doesn't have any fixes other than waiting the BLT dev on updating BLT itself, so have patience for a while.


BeardLib have recently got updated for the Luajit changes.. I suggest downloading the update manually on MWS.
The BLT update manager might ask to download BeardLib new update, but you already got the most recent one, so Ignore it..
There might be a problem on BLT update manager it seems.

All Custom Stuff (Weapon, Mask, Melee, etc) appear to have no problem in-game and doesn't cause crash (at least for me)
Not sure if it's the same case with Custom Heist asset files.

Also try purging your mod save files. Located on mods/saves.
This folder contains all the BLT mod settings data that you use. Delete all of the txt in the inside, just to be sure.
According to xtakku

Some user have found how to update old BLT mod.txt format into the new BLT 2.0 format, read more here:
https://www.reddit.com/r/paydaytheheistmods/comments/6xbpu9/tutorial_how_to_update_your_basic_lua_mods_to_blt/

If you're not using Win7, and somehow can't get Payday 2 started into main menu with BLT 2.0
Try this hook that once was used on LuaJIT beta: https://www.dropbox.com/s/dex612bkbqakisl/IPHLPAPI.dll?dl=0
Credit goes to Snh20





You got other mod that solves the instant crash when you remove it from the mods folder?
Post it here, helps other heister!

Note: this thread will only help getting your Payday 2 stable enough to not CTD on start-up and reach main menu with a working BLT 2.0 (and it's new GUI)
Crashes in-heist, looking for mod options, and any other stuff beside crashing on Payday 2 startup isn't covered here (it's an issue with many BLT mod havent been updated to BLT 2.0 format)



RE: You're crashing with the new U153 and BLT 2.0? - [Unintelligible] - 08-31-2017

Henlo, I came here to confirm that Weapon Attachement Customizer works, does not crash, changes the look of the weapons nicely. However, it is impossible to change any options for the mod.
Also, I did not have any kind of problem using Slide & Bolt catch. It's even compatible with the new pistol (woah!)


RE: You're crashing with the new U153 and BLT 2.0? - Alcat101 - 08-31-2017

Old mod that uses menu in Mod Options will have lost its option menu due to BLT changes.

The author of the mod that uses Mod Options will have to update their mod, so avoid mod that uses Mod Options until it got updated from the author


RE: You're crashing with the new U153 and BLT 2.0? - Offyerrocker - 08-31-2017

Interesting.
None of my mods actually crashed the game or prevented it from launching. In fact, almost all of the mods I have that don't require keybinds (Auto Fire Sound Fix Updated, Random Drill Skin, Hostage Escort Tweaks, Networked Lasers, Skip XP Screen, to name a few) worked perfectly fine.

Their menus need to be updated, as none of them show up in the new mod options menu entry, but they'll otherwise work fine with whatever settings they had on last.


RE: You're crashing with the new U153 and BLT 2.0? - Alcat101 - 08-31-2017

I actually removed Autofire because of the error in logs, but havent tried it putting it on.
Guess we can remove it from the list of mod that could cause crash.

Thanks for the report!


RE: You're crashing with the new U153 and BLT 2.0? - Herr Lutter - 08-31-2017

For some reasons, with latest BLT, game totally won't launch. Deleting IPHLPAPI fixes it, but everyone know what it does, e.g. no mods. Not sure what causing conflict here. Don't have any mentioned mod.


RE: You're crashing with the new U153 and BLT 2.0? - Alcat101 - 09-01-2017

It might be other mod that could causes it.

I dont use lots of BLT mod, but try removing any BLT mod that have Mod Options menu.


RE: You're crashing with the new U153 and BLT 2.0? - Herr Lutter - 09-01-2017

So i deleted all the mods, both from mods folder and mod_overrides (basically i just changed the names) and installed clean BLT.
Still the same problem, game won't launch.
When i delete IPHLPAPI.dll it opens, but crashes just after the intro, crashlog log is pretty weird, something about unequipping unowned armor skins (wtf i never chated, bah, i never used the armor skins...) ._.


RE: You're crashing with the new U153 and BLT 2.0? - Celtthulhu - 09-01-2017

Herr Lutter I was having the same crash. Let me know if you figure out what causes it, I'm stuck at work.


RE: You're crashing with the new U153 and BLT 2.0? - Alcat101 - 09-01-2017

Found some more possible solution.
Check the last paragraph on the 1st post.