We use ads to continue serving you mods and further develop the site. Whitelisting us in your ad blocker can help us a lot ❤ If you dislike ads, consider supporting us.

PSA: BLT is still working
#1
Wrench 
Far as I've seen into the PAYDAY 2 modding subforum, lots of people are posting that BLT doesn't work anymore, or that the game crashes for no reasons.

What you need to know, and as OVERKILL_Tobias said, the mods that were supposed to partially fix/remove the desync will most likely not work anymore.
List of the most obvious examples:
  • Velosync
  • Poco HUD with the desync resolve option
  • Adaptive Resync
If you have any of these examples above, you need to remove them. They are not necessary looking at how the game is now anyways.

If it still doesn't work, you should first reinstall BLT to see if the problem is the hook.

You can get an up-to-date version of BLT here : https://github.com/JamesWilko/Payday-2-BLT.
Specifically on the Releases tab: https://github.com/JamesWilko/Payday-2-BLT/releases
Extract the content of both archives to Steam/SteamApps/common/PAYDAY 2/.

Double check if you also have BLT's dependency, which is x86 2013 C++ Runtime.

If the two solutions above didn't helped, you should start to remove either all your mods, or taking them out one by one to find which mod is causing your issue. Keep in mind that some mod_overrides are causing crashes too. Don't forget to check there as well.

If you still have issues, feel free to post here. I'll see what I can do to help you.
Reply
#2
Welp, im trying to run BLT alone and it doesn't even show the in-game config options, checked every mod i have (none of them messes with sync) and nothing, i have the dependencies, everything is installed correctly and the only thing i wanted was to animate the dificulty screen and show 4 characters in the menu. I never experienced a crash nor game refusing to start tho.

PD: no, i don't mess with replacement mods, no, none of the mods i have replaces anything and where i downloaded them all said instalation with BLT required. No, neither any of them said i needed Beard's Library.

Ok, today, after writting this i played a stealth game on the jewelry store and once finishing it, just before watching the pay screen, my game crashed, i don't know if this can be some evidence
Reply
#3
do you have any log file created? into mods/logs/. pick the most recent date.
Reply
#4
the most recent log is from today, i just played some mins

09:49:53 AM Log: CURL INITD
09:56:05 AM Log: CURL CLOSED
and that's it, the older ones say the same multiple times from my tests trying to get BLT working

my log of yesterday is this:

12:21:14 AM Log: CURL CLOSED
01:05:56 AM Log: CURL INITD
01:56:54 AM Log: CURL CLOSED
02:18:14 AM Log: CURL INITD
02:19:43 AM Log: CURL CLOSED
09:21:47 AM Log: CURL INITD
09:23:04 AM Log: CURL CLOSED
12:09:46 PM Log: CURL INITD
12:11:02 PM Log: CURL CLOSED
05:55:41 PM Log: CURL INITD
05:57:18 PM Log: CURL CLOSED
05:57:28 PM Log: CURL INITD
05:58:37 PM Log: CURL CLOSED
06:32:22 PM Log: CURL INITD
06:44:43 PM Log: CURL CLOSED
06:58:14 PM Log: CURL INITD
10:17:50 PM Log: CURL CLOSED

i can't remember if i tried uninstalling blt and runing the game without it at 11:00 pm or simply didn't register anything
but what i can remember is there is no difference running the game with and without BLT, it's like is completly unexistent for the game
Reply
#5
looks like your DLL hook is outdated. try this one:


Attached Files
.zip   IPHLPAPI.zip (Size: 692.7 KB / Downloads: 24)
Reply
#6
It... fixed it?
but.. i downloaded BLT this sunday from the oficial website, since when the version there turned old?

Well, thank you so much sis :D
Reply
#7
yeah, for some weird reasons, the version on the website is outdated. lol

no problem!
Reply
#8
(07-12-2017, 07:53 AM)Nepgearsy Wrote: yeah, for some weird reasons, the version on the website is outdated. lol

no problem!

it still doesn't work after update 108 for me at least
Reply
#9
explain me whats exactly the problem. BLT that doesnt load? crash?
Reply
#10
(07-13-2017, 03:17 PM)Nepgearsy Wrote: explain me whats exactly the problem. BLT that doesnt load? crash?
it just doesn't load at all nothing new pops up signaling that i installed blt
Reply



Forum Jump:


Users browsing this thread: 1 Guest(s)